Microsoft Excel – Tratamento de Erros no Excel – SEERRO e SENÃODISP

Fabio Joaquim
Por Fabio Joaquim março 27, 2015 15:46

Microsoft Excel – Tratamento de Erros no Excel – SEERRO e SENÃODISP

Olá pessoal, tudo On?

Uma pequena dica para quem curte PROCV, PROCH, ÍNDICE, CORRESP ou DESLOC.

Às vezes, você tem um pequeno PROCV como =PROCV(A2;$Z$2:$AB$99;3;Falso). Excelente, ótima fórmula! Mas a fim de evitar a mensagem de erro #N/D! quando algo não for encontrado, você costumava ter que fazer o PROCV duas vezes: =SE(É.NÃO.DISP (PROCV(A2;$Z$2:$AB$99;3;Falso));“Não encontrado”;PROCV(A2,$Z$2:$AB$99;3;Falso)) ou  ainda em =SE(É.ERROS (PROCV(A2;$Z$2:$AB$99;3;Falso));“Não encontrado”;PROCV(A2,$Z$2:$AB$99;3;Falso)).

Isso está fica muito mais simples em Excel 2010:

=SEERRO(PROCV(A2;$Z$2:$AB$99;3;Falso);”Não Encontrado”)

E ainda melhor NO EXCEL 2013:

=SENÃODISP(PROCV(A2;$Z$2:$AB$99;3;Falso);”Não Encontrado”)

O grande diferencial do uso do SENÃODISP é que você evita que você retorne valores “Não Encontrado” em erros diferentes de #N/D!, como #VALOR!, #REF!, entre outros…

SENAODISP

Pense nisso. Vamos supor que você está fazendo 1000 PROCVs. Existem 990 que são encontrados e 10 que não são encontrados. A velha fórmula acabaria fazendo 1990 PROCVs. A(s) nova(s) fórmula(s) vai/vão fazer 1000 PROCVs. Será quase duas vezes mais rápido.

Fabio Joaquim
Por Fabio Joaquim março 27, 2015 15:46
Escreva um comentário

Nenhum comentário

Nenhum comentário ainda!

Deixe-me contar uma história triste! Não há comentários ainda, mas você pode ser o primeiro a comentar esse artigo.

Escreva um comentário
Ver comentários

Escreva um comentário

Seu endereço de e-mail não será publicado.
Campos requeridos estão marcados*

COMENTÁRIOS RECENTES

  • Todi

    Todi

    Ótimo obrigado.

    Ver artigo
  • Victor

    Victor

    Fiz os treinamentos de Excel Básico e Intermediário. Ambos são excelentes e proporcionam um ótimo domínio da ferramenta para que…

    Ver artigo
  • PL

    PL

    Ajudou pacas, muito prático. vlw.

    Ver artigo

AGENDA

ENCONTRE-NOS NO FACEBOOK

CADASTRE-SE PARA NOVIDADES