Microsoft Excel – Procurando com 2 condições

Fabio Joaquim
Por Fabio Joaquim novembro 8, 2010 23:06

Microsoft Excel – Procurando com 2 condições

Olá Pessoal!

Vou começar a mesclar as coisas por aqui. Não posso apenas dar dicas muito básicas para vocês, desta vez, falarei para o pessoal mais avançado.

Quem aí já teve a necessidade de fazer um PROCV com 2 critérios ou mais? Vou mostrar um exemplo do que quero dizer:

2 Condições

Muitos ensinariam aqui que você deve criar uma coluna extra, concatenar as duas ou mais chaves desejadas para realizar o PROCV. Vou fazer diferente e tenho certeza que vocês vão adorar:

Primeiro, crie uma área onde você vai informar os critérios:

Área de critérios

Agora você precisa criar uma função que analise os critérios e a nossa tabelinha. Vamos lá?

Vamos trabalhar com duas funções que quando se juntam, vira uma festa: ÍNDICE E CORRESP. Na célula F4 digite =ÍNDICE(B2:B9;CORRESP(F2&F3;A2:A9&C2:C9;0)) e ao final pressione CRTL + SHIFT + ENTER para transformar esta função em uma matricial.

Índice e Corresp

Depois do CRTL + SHIFT + ENTER ficará assim:

Índice e Corresp 2

Vamos aos detalhes: A função ÍNDICE permite localizar um valor em uma matriz a partir de sua posição de linha e coluna. A matriz é de B2 até B9, você não sabe a linha onde a informação está, portanto, você precisa de algum recurso que permite localizar a posição do item ou no nosso caso itens que você pesquisa. Usaremos então CORRESP que vai pesquisar o conteúdo de F2 concatenado com F3, na matriz A2 até A9 concatenado com C2 até C9 com resultado exato (por isso o zero no final da função). Como não me interessa a coluna desejada, ignoro esta opção na minha função ÍNDICE. Pressiono CTRL + SHIFT + ENTER para gerar uma função matricial e pronto. Você acaba de encontrar o resultado da concatenação de dois critérios, sem usar PROCV.

Por essa você não esperava não é? Espero poder ajudar vocês em breve, mais e mais, comentem, divulguem, entrem em contato, pois este blog é para vocês.

Forte abraço! Auf Wiedersehen!

Fabio Joaquim
Por Fabio Joaquim novembro 8, 2010 23:06
Escreva um comentário

4 Comentários

  1. Pietro março 5, 11:43

    Fabio, será que na formula PROCV quando utilizada par buscar dados de diferentes planilhas dentro do mesmo arquivo posso alterar a formula para que o nome da planilha seja buscado em alguma célula e não tenha que ser alterdo/digitado manualmente para cada uma das planilhas ??

    Exemplo:
    Formula convenciaonal: =PROCV(A1;Plan1!A1:B3;2;)

    O que eu preciso:
    =PROCV(A1;A5!A1:B3;2;)

    É possível ??

    Responder esse comentário
  2. Jonas setembro 12, 16:47

    Olá Fabio

    Existe a possibilidade de se fazer um indice + corresp de 2 condições e que mostre varios resultados.

    não encontro isso em nenhum lugar.

    Obrigado

    Responder esse comentário
Ver comentários

Escreva um comentário

Seu endereço de e-mail não será publicado.
Campos requeridos estão marcados*

COMENTÁRIOS RECENTES

  • Todi

    Todi

    Ótimo obrigado.

    Ver artigo
  • Victor

    Victor

    Fiz os treinamentos de Excel Básico e Intermediário. Ambos são excelentes e proporcionam um ótimo domínio da ferramenta para que…

    Ver artigo
  • PL

    PL

    Ajudou pacas, muito prático. vlw.

    Ver artigo

AGENDA

ENCONTRE-NOS NO FACEBOOK

CADASTRE-SE PARA NOVIDADES