Microsoft Excel – Função Escolher

Fabio Joaquim
Por Fabio Joaquim maio 23, 2016 16:33

Microsoft Excel – Função Escolher

Olá pessoal, tudo On?

O Microsoft Excel tem algumas fórmulas muito bacanas para tomada de decisão – especialmente a função SE. Uma das suas melhores características é que ele pode ser aninhado para permitir cenários complexos. No entanto o que acontece se o número de combinações é muito complexo? As fórmulas podem tornar-se muito complicadas com bastante facilidade. Uma boa maneira de evitar esta complexidade, é utilizar a função ESCOLHER.

Imagine que queríamos na célula B2 para retornar o mês do ano como um valor de texto, dependendo do valor da célula A1. Assim, por exemplo, se tivéssemos 3 em A1, em seguida, B2 retornaria “Março.

Função Escolher

As fórmulas IF aninhadas para isso é (até Abril):

=SE(A1=1;”Janeiro”;SE(A1=2;“Fevereiro”;SE(A1=3;“Março“;SE(A1=4;”Abril”))))

Vemos que as fórmulas SE aninhadas para isso está ficando muito complicado já – embora apenas ter coberto os primeiros 4 meses. Pode-se imaginar que, para todos os 12 meses que iria ficar muito confuso, de fato.

A alternativa é a função ESCOLHER:

ESCOLHER (Parâmetro da célula; Opção 1; Opção 2; Opção 3;…;Opção X)

Portanto, neste caso, temos:

Na célula B2 a seguinte fórmula =ESCOLHER (A1;“Janeiro”;“Fevereiro”;“Março“;”Abril”;“Maio”;“Junho“;“Julho”; …;”Dezembro”)

Função Escolher 2

Isto é muito mais fácil de ler do que uma declaração SE composta mais complexa. Mais importante, os argumentos de uma função ESCOLHER podem ser fórmulas, bem como texto. Assim :-

=ESCOLHER(A1; AR2*AR3;AR3*AR4;AR4*AR5;AR5*AR6)

Isso acaba sendo muito mais fácil de fazer do que:
=SE(A1=1;AR2*AR3;SE(A1=2;AR3*AR4;SE(A1=3;AR4*AR5;(SE(A1=5;AR5*AR6))))

Espero que tenham gostado de mais uma matéria da On Training! Curta e compartilhe este post para outros amigos que só conhecem a função SE e tiram a maior onda. Tire onda você também! Forte abraço e até a próxima.

Fabio Joaquim
Por Fabio Joaquim maio 23, 2016 16:33
Escreva um comentário

Nenhum comentário

Nenhum comentário ainda!

Deixe-me contar uma história triste! Não há comentários ainda, mas você pode ser o primeiro a comentar esse artigo.

Escreva um comentário
Ver comentários

Escreva um comentário

Seu endereço de e-mail não será publicado.
Campos requeridos estão marcados*

COMENTÁRIOS RECENTES

  • Todi

    Todi

    Ótimo obrigado.

    Ver artigo
  • Victor

    Victor

    Fiz os treinamentos de Excel Básico e Intermediário. Ambos são excelentes e proporcionam um ótimo domínio da ferramenta para que…

    Ver artigo
  • PL

    PL

    Ajudou pacas, muito prático. vlw.

    Ver artigo

AGENDA

ENCONTRE-NOS NO FACEBOOK

CADASTRE-SE PARA NOVIDADES